wordpressWordPress released a new security update 3.9.2 on Aug 6, 2014 eliminating a recently discovered security hole affecting several content management platforms. This hole allows an attacker to flood the website with requests that can overwhelm the server and crash the site. The issue was only recently discovered, and is fixed by the 3.9.2 update.

If your WordPress site is running the current version with auto-updates, the new fix should be installed automatically. If you are not running a current version, or do not have auto-updates, then this new version should be installed immediately.

As always, we recommend doing a full site backup before installing any updates. Please contact MainStreetOpen.com if you need assistance or support.